What’s Vulnerable › Vulnerabilities
CVE-2010-3069
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-09-15 · updated 2026-06-16
- Weakness: CWE-119
Description
Stack-based buffer overflow in the (1) sid_parse and (2) dom_sid_parse functions in Samba before 3.5.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted Windows Security ID (SID) on a file share.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.04, 9.10, 10.04
- Samba: from 3.0.0 through 3.3.14; from 3.4.0 before 3.4.9; from 3.5.0 before 3.5.5 — fixed in 3.4.9, 3.5.5
How to fix
Upgrade to a fixed version: Samba 3.4.9, 3.5.5. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2011//Jun/msg00000.html
- http://lists.apple.com/archives/security-announce/2011/Mar/msg00006.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-September/047650.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-September/047697.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-September/047758.html
- http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00006.html
- http://marc.info/?l=bugtraq&m=130835366526620&w=2
- http://secunia.com/advisories/41354
- http://secunia.com/advisories/41447
- http://secunia.com/advisories/42531
- http://secunia.com/advisories/42885
Get alerted when CVE-2010-3069 or the next vulnerability affects your stack