What’s Vulnerable › Vulnerabilities
CVE-2010-3080
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-09-21 · updated 2026-06-16
- Weakness: CWE-415
Description
Double free vulnerability in the snd_seq_oss_open function in sound/core/seq/oss/seq_oss_init.c in the Linux kernel before 2.6.36-rc4 might allow local users to cause a denial of service or possibly have unspecified other impact via an unsuccessful attempt to open the /dev/sequencer device.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.04, 9.10, 10.04, 10.10
- Linux kernel: before 2.6.36; 2.6.36, 2.6.36-rc1, 2.6.36-rc2, 2.6.36-rc3 — fixed in 2.6.36
- Opensuse: 11.1
- SUSE Linux Enterprise Server 15 SP1: 11-sp1
- SUSE Linux Enterprise Real Time Extension: 11-sp1
- SUSE Linux Enterprise Server: 11-sp1
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git%3Ba=commit%3Bh=c598337660c21c0afaa9df5a65bb4a7a0cf15be8
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=27f7ad53829f79e799a253285318bff79ece15bd
- http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2010-11/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00000.html
- http://secunia.com/advisories/42890
- http://www.kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.36-rc4
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:198
- http://www.openwall.com/lists/oss-security/2010/09/08/7
- http://www.redhat.com/support/errata/RHSA-2011-0007.html
- http://www.securityfocus.com/bid/43062
- http://www.ubuntu.com/usn/USN-1000-1
Get alerted when CVE-2010-3080 or the next vulnerability affects your stack