What’s Vulnerable › Vulnerabilities

CVE-2010-3116

Description

Multiple use-after-free vulnerabilities in WebKit, as used in Apple Safari before 4.1.3 and 5.0.x before 5.0.3, Google Chrome before 5.0.375.127, and webkitgtk before 1.2.6, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via vectors related to improper handling of MIME types by plug-ins.

Affected products

How to fix

Upgrade to a fixed version: Apple Iphone Os 4.2; Apple Safari 4.1.3, 5.0.3; Google Chrome 5.0.375.127; Webkit 1.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-3116 or the next vulnerability affects your stack