What’s Vulnerable › Vulnerabilities
CVE-2010-3119
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-08-24 · updated 2026-06-16
- Weakness: CWE-119
Description
Google Chrome before 5.0.375.127 and webkitgtk before 1.2.6 do not properly support the Ruby language, which allows attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors.
Affected products
- Google Chrome: before 5.0.375.127 — fixed in 5.0.375.127
- Webkit: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: Google Chrome 5.0.375.127; Webkit 1.2.6. Check the vendor advisory for mitigations.
References
- http://code.google.com/p/chromium/issues/detail?id=51654
- http://googlechromereleases.blogspot.com/2010/08/stable-channel-update_19.html
- http://secunia.com/advisories/43086
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:039
- http://www.redhat.com/support/errata/RHSA-2011-0177.html
- http://www.vupen.com/english/advisories/2011/0216
- http://www.vupen.com/english/advisories/2011/0552
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A12107
- http://code.google.com/p/chromium/issues/detail?id=51654
- http://googlechromereleases.blogspot.com/2010/08/stable-channel-update_19.html
- http://secunia.com/advisories/43086
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:039
Get alerted when CVE-2010-3119 or the next vulnerability affects your stack