What’s Vulnerable › Vulnerabilities

CVE-2010-3257

Description

Use-after-free vulnerability in WebKit, as used in Apple Safari before 4.1.3 and 5.0.x before 5.0.3, Google Chrome before 6.0.472.53, and webkitgtk before 1.2.6, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via vectors involving element focus.

Affected products

How to fix

Upgrade to a fixed version: Apple Iphone Os 4.2; Apple Safari 4.1.3, 5.0.3; Google Chrome 6.0.472.53; Webkit 1.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-3257 or the next vulnerability affects your stack