What’s Vulnerable › Vulnerabilities
CVE-2010-3436
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-11-09 · updated 2026-06-16
- Weakness: CWE-264
Description
fopen_wrappers.c in PHP 5.3.x through 5.3.3 might allow remote attackers to bypass open_basedir restrictions via vectors related to the length of a filename.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.10, 10.04, 10.10
- PHP: from 5.2.0 before 5.2.15; from 5.3.0 before 5.3.4 — fixed in 5.2.15, 5.3.4
How to fix
Upgrade to a fixed version: PHP 5.2.15, 5.3.4. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/Security-announce/2011//Oct/msg00003.html
- http://lists.apple.com/archives/security-announce/2011/Mar/msg00006.html
- http://secunia.com/advisories/42729
- http://secunia.com/advisories/42812
- http://security-tracker.debian.org/tracker/CVE-2010-3436
- http://slackware.com/security/viewer.php?l=slackware-security&y=2010&m=slackware-security.490619
- http://support.apple.com/kb/HT4581
- http://support.apple.com/kb/HT5002
- http://svn.php.net/viewvc/php/php-src/trunk/main/fopen_wrappers.c?r1=303824&r2=303823&pathrev=303824
- http://svn.php.net/viewvc?view=revision&revision=303824
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:218
- http://www.php.net/ChangeLog-5.php
Get alerted when CVE-2010-3436 or the next vulnerability affects your stack