What’s Vulnerable › Vulnerabilities
CVE-2010-3440
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-12 · updated 2026-06-16
- Weakness: CWE-494
Description
babiloo 2.0.9 before 2.0.11 creates temporary files with predictable names when downloading and unpacking dictionary files, allowing a local attacker to overwrite arbitrary files.
Affected products
- Babiloo Project Babiloo: from 2.0.9 before 2.0.11 — fixed in 2.0.11
- Debian Linux: 8.0, 9.0, 10.0
How to fix
Upgrade to a fixed version: Babiloo Project Babiloo 2.0.11. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2010-3440
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=591995
- https://security-tracker.debian.org/tracker/CVE-2010-3440
- https://access.redhat.com/security/cve/cve-2010-3440
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=591995
- https://security-tracker.debian.org/tracker/CVE-2010-3440
Get alerted when CVE-2010-3440 or the next vulnerability affects your stack