What’s Vulnerable › Vulnerabilities
CVE-2010-3450
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-01-28 · updated 2026-06-16
- Weakness: CWE-22
Description
Multiple directory traversal vulnerabilities in OpenOffice.org (OOo) 2.x and 3.x before 3.3 allow remote attackers to overwrite arbitrary files via a .. (dot dot) in an entry in (1) an XSLT JAR filter description file, (2) an Extension (aka OXT) file, or unspecified other (3) JAR or (4) ZIP files.
Affected products
- Apache Software Foundation Apache OpenOffice: from 2.0.0 before 3.3.0 — fixed in 3.3.0
- Canonical Ubuntu Linux: 8.04, 9.10, 10.04, 10.10
- Debian Linux: 5.0, 6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenOffice 3.3.0. Check the vendor advisory for mitigations.
References
- http://osvdb.org/70711
- http://secunia.com/advisories/40775
- http://secunia.com/advisories/42999
- http://secunia.com/advisories/43065
- http://secunia.com/advisories/43105
- http://secunia.com/advisories/43118
- http://secunia.com/advisories/60799
- http://ubuntu.com/usn/usn-1056-1
- http://www.debian.org/security/2011/dsa-2151
- http://www.gentoo.org/security/en/glsa/glsa-201408-19.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:027
- http://www.openoffice.org/security/cves/CVE-2010-3450.html
Get alerted when CVE-2010-3450 or the next vulnerability affects your stack