What’s Vulnerable › Vulnerabilities
CVE-2010-3453
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-01-28 · updated 2026-06-16
- Weakness: CWE-787
Description
The WW8ListManager::WW8ListManager function in oowriter in OpenOffice.org (OOo) 2.x and 3.x before 3.3 does not properly handle an unspecified number of list levels in user-defined list styles in WW8 data in a Microsoft Word document, which allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted .DOC file that triggers an out-of-bounds write.
Affected products
- Apache Software Foundation Apache OpenOffice: from 2.0.0 before 3.3.0 — fixed in 3.3.0
- Canonical Ubuntu Linux: 8.04, 9.10, 10.04, 10.10
- Debian Linux: 5.0, 6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenOffice 3.3.0. Check the vendor advisory for mitigations.
References
- http://osvdb.org/70714
- http://secunia.com/advisories/40775
- http://secunia.com/advisories/42999
- http://secunia.com/advisories/43065
- http://secunia.com/advisories/43105
- http://secunia.com/advisories/43118
- http://secunia.com/advisories/60799
- http://ubuntu.com/usn/usn-1056-1
- http://www.cs.brown.edu/people/drosenbe/research.html
- http://www.debian.org/security/2011/dsa-2151
- http://www.gentoo.org/security/en/glsa/glsa-201408-19.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:027
Get alerted when CVE-2010-3453 or the next vulnerability affects your stack