What’s Vulnerable › Vulnerabilities
CVE-2010-3637
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-11-07 · updated 2026-06-16
- Weakness: CWE-119
Description
An unspecified ActiveX control in Adobe Flash Player before 9.0.289.0 and 10.x before 10.1.102.64 (Flash10h.ocx) on Windows allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted FLV video.
Affected products
- Adobe Flash Player 24.0.0.186 and earlier.: from 9.0 before 9.0.289.0; from 10.0 before 10.1.102.64 — fixed in 10.1.102.64, 9.0.289.0
How to fix
Upgrade to a fixed version: Adobe Flash Player 24.0.0.186 and earlier. 10.1.102.64, 9.0.289.0. Check the vendor advisory for mitigations.
References
- http://blogs.sun.com/security/entry/multiple_vulnerabilities_in_adobe_flash1
- http://lists.opensuse.org/opensuse-security-announce/2010-11/msg00002.html
- http://marc.info/?l=bugtraq&m=130331642631603&w=2
- http://secunia.com/advisories/42926
- http://www.adobe.com/support/security/bulletins/apsb10-26.html
- http://www.securityfocus.com/archive/1/514652/100/0/threaded
- http://www.securityfocus.com/bid/44690
- http://www.vupen.com/english/advisories/2010/2903
- http://www.vupen.com/english/advisories/2011/0173
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A12259
- http://blogs.sun.com/security/entry/multiple_vulnerabilities_in_adobe_flash1
- http://lists.opensuse.org/opensuse-security-announce/2010-11/msg00002.html
Get alerted when CVE-2010-3637 or the next vulnerability affects your stack