What’s Vulnerable › Vulnerabilities
CVE-2010-3705
- Severity: high (CVSS 8.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-11-26 · updated 2026-06-16
- Weakness: CWE-400
Description
The sctp_auth_asoc_get_hmac function in net/sctp/auth.c in the Linux kernel before 2.6.36 does not properly validate the hmac_ids array of an SCTP peer, which allows remote attackers to cause a denial of service (memory corruption and panic) via a crafted value in the last element of this array.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.04, 9.10, 10.04, 10.10
- Debian Linux: 5.0
- Fedoraproject Fedora: 13
- Linux kernel: before 2.6.36 — fixed in 2.6.36
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/davem/net-2.6.git%3Ba=commit%3Bh=51e97a12bef19b7e43199fc153cf9bd5f2140362
- http://lists.fedoraproject.org/pipermail/package-announce/2010-December/052513.html
- http://marc.info/?l=linux-kernel&m=128596992418814&w=2
- http://secunia.com/advisories/42745
- http://www.debian.org/security/2010/dsa-2126
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.36
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:029
- http://www.openwall.com/lists/oss-security/2010/10/04/2
- http://www.openwall.com/lists/oss-security/2010/10/04/7
- http://www.redhat.com/support/errata/RHSA-2010-0842.html
- http://www.redhat.com/support/errata/RHSA-2010-0958.html
- http://www.ubuntu.com/usn/USN-1000-1
Get alerted when CVE-2010-3705 or the next vulnerability affects your stack