What’s Vulnerable › Vulnerabilities
CVE-2010-3850
- Severity: low (CVSS 2.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-12-30 · updated 2026-06-16
Description
The ec_dev_ioctl function in net/econet/af_econet.c in the Linux kernel before 2.6.36.2 does not require the CAP_NET_ADMIN capability, which allows local users to bypass intended access restrictions and configure econet addresses via an SIOCSIFADDR ioctl call.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.10, 10.04, 10.10
- Debian Linux: 5.0
- Linux kernel: before 2.6.36.2 — fixed in 2.6.36.2
- SUSE Linux Enterprise Server 15 SP1: 10-sp3
- SUSE Linux Enterprise Real Time Extension: 11-sp1
- SUSE Linux Enterprise Server: 9, 10-sp3
- SUSE Linux Enterprise Software Development Kit: 10-sp3
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36.2. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/fulldisclosure/2010-12/0086.html
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=16c41745c7b92a243d0874f534c1655196c64b74
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00002.html
- http://openwall.com/lists/oss-security/2010/11/30/1
- http://secunia.com/advisories/43056
- http://secunia.com/advisories/43291
- http://www.debian.org/security/2010/dsa-2126
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.36.2
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:257
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:051
Get alerted when CVE-2010-3850 or the next vulnerability affects your stack