What’s Vulnerable › Vulnerabilities
CVE-2010-3870
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-11-12 · updated 2026-06-16
- Weakness: CWE-20
Description
The utf8_decode function in PHP before 5.3.4 does not properly handle non-shortest form UTF-8 encoding and ill-formed subsequences in UTF-8 data, which makes it easier for remote attackers to bypass cross-site scripting (XSS) and SQL injection protection mechanisms via a crafted string.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.10, 10.04, 10.10
- PHP: before 5.2.14; from 5.3.0 before 5.3.4 — fixed in 5.2.14, 5.3.4
How to fix
Upgrade to a fixed version: PHP 5.2.14, 5.3.4. Check the vendor advisory for mitigations.
References
- http://bugs.php.net/bug.php?id=48230
- http://bugs.php.net/bug.php?id=49687
- http://lists.apple.com/archives/security-announce/2011/Mar/msg00006.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052836.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052845.html
- http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00000.html
- http://marc.info/?l=bugtraq&m=133469208622507&w=2
- http://secunia.com/advisories/42410
- http://secunia.com/advisories/42812
- http://sirdarckcat.blogspot.com/2009/10/couple-of-unicode-issues-on-php-and.html
- http://support.apple.com/kb/HT4581
- http://svn.php.net/viewvc?view=revision&revision=304959
Get alerted when CVE-2010-3870 or the next vulnerability affects your stack