What’s Vulnerable › Vulnerabilities
CVE-2010-3873
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-01-03 · updated 2026-06-16
- Weakness: CWE-119
Description
The X.25 implementation in the Linux kernel before 2.6.36.2 does not properly parse facilities, which allows remote attackers to cause a denial of service (heap memory corruption and panic) or possibly have unspecified other impact via malformed (1) X25_FAC_CALLING_AE or (2) X25_FAC_CALLED_AE data, related to net/x25/x25_facilities.c and net/x25/x25_in.c, a different vulnerability than CVE-2010-4164.
Affected products
- Debian Linux: 5.0
- Linux kernel: before 2.6.36.2 — fixed in 2.6.36.2
- Opensuse: 11.4
- SUSE Linux Enterprise Server: 9
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36.2. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=a6331d6f9a4298173b413cf99a40cc86a9d92c37
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00005.html
- http://openwall.com/lists/oss-security/2010/11/03/2
- http://openwall.com/lists/oss-security/2010/11/04/3
- http://secunia.com/advisories/43291
- http://www.debian.org/security/2010/dsa-2126
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.36.2
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:029
- http://www.spinics.net/lists/netdev/msg145786.html
- http://www.spinics.net/lists/netdev/msg145873.html
- http://www.vupen.com/english/advisories/2011/0375
Get alerted when CVE-2010-3873 or the next vulnerability affects your stack