What’s Vulnerable › Vulnerabilities
CVE-2010-4073
- Severity: low (CVSS 1.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-11-29 · updated 2026-06-16
- Weakness: CWE-200
Description
The ipc subsystem in the Linux kernel before 2.6.37-rc1 does not initialize certain structures, which allows local users to obtain potentially sensitive information from kernel stack memory via vectors related to the (1) compat_sys_semctl, (2) compat_sys_msgctl, and (3) compat_sys_shmctl functions in ipc/compat.c; and the (4) compat_sys_mq_open and (5) compat_sys_mq_getsetattr functions in ipc/compat_mq.c.
Affected products
- Debian Linux: 5.0
- Linux kernel: before 2.6.37 — fixed in 2.6.37
- Opensuse: 11.3
- SUSE Linux Enterprise Server 15 SP1: 10-sp3, 11-sp1
- SUSE Linux Enterprise Real Time Extension: 11-sp1
- SUSE Linux Enterprise Server: 9, 10-sp3, 11-sp1
- SUSE Linux Enterprise Software Development Kit: 10-sp3
How to fix
Upgrade to a fixed version: Linux kernel 2.6.37. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=03145beb455cf5c20a761e8451e30b8a74ba58d9
- http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00002.html
- http://lkml.org/lkml/2010/10/6/492
- http://secunia.com/advisories/42778
- http://secunia.com/advisories/42884
- http://secunia.com/advisories/42890
- http://secunia.com/advisories/42932
- http://secunia.com/advisories/42963
Get alerted when CVE-2010-4073 or the next vulnerability affects your stack