What’s Vulnerable › Vulnerabilities
CVE-2010-4157
- Severity: medium (CVSS 6.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-12-10 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in the ioc_general function in drivers/scsi/gdth.c in the Linux kernel before 2.6.36.1 on 64-bit platforms allows local users to cause a denial of service (memory corruption) or possibly have unspecified other impact via a large argument in an ioctl call.
Affected products
- Fedoraproject Fedora: 13
- Linux kernel: before 2.6.36.1 — fixed in 2.6.36.1
- Opensuse: 11.2, 11.3
- SUSE Linux Enterprise Server 15 SP1: 10-sp3, 11-sp1
- SUSE Linux Enterprise Real Time Extension: 11-sp1
- SUSE Linux Enterprise Server: 9, 10-sp3, 11-sp1
- SUSE Linux Enterprise Software Development Kit: 10-sp3
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36.1. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=f63ae56e4e97fb12053590e41a4fa59e7daa74a4
- http://lists.fedoraproject.org/pipermail/package-announce/2010-December/052513.html
- http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00002.html
- http://ns3.spinics.net/lists/linux-scsi/msg47361.html
- http://openwall.com/lists/oss-security/2010/11/09/1
- http://openwall.com/lists/oss-security/2010/11/09/3
- http://openwall.com/lists/oss-security/2010/11/09/4
Get alerted when CVE-2010-4157 or the next vulnerability affects your stack