What’s Vulnerable › Vulnerabilities
CVE-2010-4160
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2011-01-07 · updated 2026-06-16
- Weakness: CWE-190
Description
Multiple integer overflows in the (1) pppol2tp_sendmsg function in net/l2tp/l2tp_ppp.c, and the (2) l2tp_ip_sendmsg function in net/l2tp/l2tp_ip.c, in the PPPoL2TP and IPoL2TP implementations in the Linux kernel before 2.6.36.2 allow local users to cause a denial of service (heap memory corruption and panic) or possibly gain privileges via a crafted sendto call.
Affected products
- Linux kernel: before 2.6.36.2 — fixed in 2.6.36.2
- Opensuse: 11.2
- SUSE Linux Enterprise Server 15 SP1: 10-sp3, 11-sp1
- SUSE Linux Enterprise Server: 9, 10-sp3, 11-sp1
- SUSE Linux Enterprise Software Development Kit: 10-sp3
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36.2. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=253eacc070b114c2ec1f81b067d2fed7305467b0
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=8acfe468b0384e834a303f08ebc4953d72fb690a
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00002.html
- http://openwall.com/lists/oss-security/2010/11/10/16
- http://openwall.com/lists/oss-security/2010/11/10/5
- http://openwall.com/lists/oss-security/2010/11/24/12
- http://openwall.com/lists/oss-security/2010/11/24/4
- http://openwall.com/lists/oss-security/2010/11/24/5
- http://openwall.com/lists/oss-security/2010/11/24/6
Get alerted when CVE-2010-4160 or the next vulnerability affects your stack