What’s Vulnerable › Vulnerabilities
CVE-2010-4164
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-01-03 · updated 2026-06-16
- Weakness: CWE-191
Description
Multiple integer underflows in the x25_parse_facilities function in net/x25/x25_facilities.c in the Linux kernel before 2.6.36.2 allow remote attackers to cause a denial of service (system crash) via malformed X.25 (1) X25_FAC_CLASS_A, (2) X25_FAC_CLASS_B, (3) X25_FAC_CLASS_C, or (4) X25_FAC_CLASS_D facility data, a different vulnerability than CVE-2010-3873.
Affected products
- Debian Linux: 5.0
- Linux kernel: before 2.6.36.2 — fixed in 2.6.36.2
- Opensuse: 11.2, 11.3
- SUSE Linux Enterprise Server 15 SP1: 10-sp3, 11-sp1
- SUSE Linux Enterprise Real Time Extension: 11-sp1
- SUSE Linux Enterprise Server: 9, 10-sp3, 11-sp1
- SUSE Linux Enterprise Software Development Kit: 10-sp3
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36.2. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=5ef41308f94dcbb3b7afc56cdef1c2ba53fa5d2f
- http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00002.html
- http://marc.info/?l=linux-netdev&m=128951543005554&w=2
- http://openwall.com/lists/oss-security/2010/11/11/2
- http://openwall.com/lists/oss-security/2010/11/12/3
- http://secunia.com/advisories/42778
- http://secunia.com/advisories/42801
Get alerted when CVE-2010-4164 or the next vulnerability affects your stack