What’s Vulnerable › Vulnerabilities

CVE-2010-4180

Description

OpenSSL before 0.9.8q, and 1.0.x before 1.0.0c, when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled, does not properly prevent modification of the ciphersuite in the session cache, which allows remote attackers to force the downgrade to an unintended cipher via vectors involving sniffing network traffic to discover a session identifier.

Affected products

How to fix

Upgrade to a fixed version: nginx 0.9.2; OpenSSL 0.9.8q, 1.0.0c. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-4180 or the next vulnerability affects your stack