What’s Vulnerable › Vulnerabilities
CVE-2010-4197
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-11-06 · updated 2026-06-16
- Weakness: CWE-416
Description
Use-after-free vulnerability in WebKit, as used in Google Chrome before 7.0.517.44, webkitgtk before 1.2.6, and other products, allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors involving text editing.
Affected products
- Fedoraproject Fedora: 13
- Google Chrome: before 7.0.517.44 — fixed in 7.0.517.44
- Webkit: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: Google Chrome 7.0.517.44; Webkit 1.2.6. Check the vendor advisory for mitigations.
References
- http://code.google.com/p/chromium/issues/detail?id=51602
- http://googlechromereleases.blogspot.com/2010/11/stable-channel-update.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052906.html
- http://secunia.com/advisories/42109
- http://secunia.com/advisories/43086
- http://trac.webkit.org/changeset/70594
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:039
- http://www.redhat.com/support/errata/RHSA-2011-0177.html
- http://www.securityfocus.com/bid/45720
- http://www.vupen.com/english/advisories/2011/0216
- http://www.vupen.com/english/advisories/2011/0552
- https://bugs.webkit.org/show_bug.cgi?id=48349
Get alerted when CVE-2010-4197 or the next vulnerability affects your stack