What’s Vulnerable › Vulnerabilities
CVE-2010-4198
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-11-06 · updated 2026-06-16
- Weakness: CWE-20
Description
WebKit, as used in Google Chrome before 7.0.517.44, webkitgtk before 1.2.6, and other products, does not properly handle large text areas, which allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted HTML document.
Affected products
- Fedoraproject Fedora: 13
- Google Chrome: before 7.0.517.44 — fixed in 7.0.517.44
- Webkit: 1.2.6
How to fix
Upgrade to a fixed version: Google Chrome 7.0.517.44. Check the vendor advisory for mitigations.
References
- http://code.google.com/p/chromium/issues/detail?id=55257
- http://googlechromereleases.blogspot.com/2010/11/stable-channel-update.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052906.html
- http://secunia.com/advisories/42109
- http://secunia.com/advisories/43086
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:039
- http://www.redhat.com/support/errata/RHSA-2011-0177.html
- http://www.securityfocus.com/bid/45719
- http://www.vupen.com/english/advisories/2011/0216
- http://www.vupen.com/english/advisories/2011/0552
- https://bugs.webkit.org/show_bug.cgi?id=45611
- https://bugzilla.redhat.com/show_bug.cgi?id=656118
Get alerted when CVE-2010-4198 or the next vulnerability affects your stack