What’s Vulnerable › Vulnerabilities
CVE-2010-4344: Exim Heap-Based Buffer Overflow Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 71.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-12-14 · updated 2026-06-16
- Weakness: CWE-787
Description
Heap-based buffer overflow in the string_vformat function in string.c in Exim before 4.70 allows remote attackers to execute arbitrary code via an SMTP session that includes two MAIL commands in conjunction with a large message containing crafted headers, leading to improper rejection logging.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.10
- Debian Linux: 5.0
- Exim: before 4.70 — fixed in 4.70
- Opensuse: 11.1, 11.2, 11.3
How to fix
Upgrade to a fixed version: Exim 4.70. Check the vendor advisory for mitigations.
References
- http://atmail.com/blog/2010/atmail-6204-now-available/
- http://bugs.exim.org/show_bug.cgi?id=787
- http://git.exim.org/exim.git/commit/24c929a27415c7cfc7126c47e4cad39acf3efa6b
- http://lists.exim.org/lurker/message/20101210.164935.385e04d0.en.html
- http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00003.html
- http://openwall.com/lists/oss-security/2010/12/10/1
- http://secunia.com/advisories/40019
- http://secunia.com/advisories/42576
- http://secunia.com/advisories/42586
- http://secunia.com/advisories/42587
- http://secunia.com/advisories/42589
Get alerted when CVE-2010-4344 or the next vulnerability affects your stack