What’s Vulnerable › Vulnerabilities
CVE-2010-4653
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-13 · updated 2026-06-16
- Weakness: CWE-190
Description
An integer overflow condition in poppler before 0.16.3 can occur when parsing CharCodes for fonts.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- poppler: before 0.16.3 — fixed in 0.16.3
How to fix
Upgrade to a fixed version: poppler 0.16.3. Check the vendor advisory for mitigations.
References
- http://security.gentoo.org/glsa/glsa-201310-03.xml
- http://www.securityfocus.com/bid/45948
- https://access.redhat.com/security/cve/cve-2010-4653
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4653
- https://security-tracker.debian.org/tracker/CVE-2010-4653
- http://security.gentoo.org/glsa/glsa-201310-03.xml
- http://www.securityfocus.com/bid/45948
- https://access.redhat.com/security/cve/cve-2010-4653
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4653
- https://security-tracker.debian.org/tracker/CVE-2010-4653
Get alerted when CVE-2010-4653 or the next vulnerability affects your stack