What’s Vulnerable › Vulnerabilities
CVE-2010-4654
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-13 · updated 2026-06-16
- Weakness: CWE-74
Description
poppler before 0.16.3 has malformed commands that may cause corruption of the internal stack.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- poppler: before 0.16.3 — fixed in 0.16.3
How to fix
Upgrade to a fixed version: poppler 0.16.3. Check the vendor advisory for mitigations.
References
- http://security.gentoo.org/glsa/glsa-201310-03.xml
- https://access.redhat.com/security/cve/cve-2010-4654
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4654
- https://security-tracker.debian.org/tracker/CVE-2010-4654
- http://security.gentoo.org/glsa/glsa-201310-03.xml
- https://access.redhat.com/security/cve/cve-2010-4654
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4654
- https://security-tracker.debian.org/tracker/CVE-2010-4654
Get alerted when CVE-2010-4654 or the next vulnerability affects your stack