What’s Vulnerable › Vulnerabilities
CVE-2010-4657
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-13 · updated 2026-06-16
- Weakness: CWE-772
Description
PHP5 before 5.4.4 allows passing invalid utf-8 strings via the xmlTextWriterWriteAttribute, which are then misparsed by libxml2. This results in memory leak into the resulting output.
Affected products
- Debian Linux: 8.0
- PHP: from 5.0.0 before 5.4.4 — fixed in 5.4.4
- Red Hat Enterprise Linux: 5.0, 6.0
How to fix
Upgrade to a fixed version: PHP 5.4.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2010-4657
- https://bugs.launchpad.net/php/%2Bbug/655442
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4657
- https://security-tracker.debian.org/tracker/CVE-2010-4657
- https://access.redhat.com/security/cve/cve-2010-4657
- https://bugs.launchpad.net/php/%2Bbug/655442
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4657
- https://security-tracker.debian.org/tracker/CVE-2010-4657
Get alerted when CVE-2010-4657 or the next vulnerability affects your stack