What’s Vulnerable › Vulnerabilities
CVE-2010-4664
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-13 · updated 2026-06-16
- Weakness: CWE-269
Description
In ConsoleKit before 0.4.2, an intended security policy restriction bypass was found. This flaw allows an authenticated system user to escalate their privileges by initiating a remote VNC session.
Affected products
- Consolekit Project Consolekit: before 0.4.2 — fixed in 0.4.2
- Debian Linux: 8.0, 9.0
- Red Hat Enterprise Linux: 6.0
How to fix
Upgrade to a fixed version: Consolekit Project Consolekit 0.4.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2010-4664
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4664
- https://security-tracker.debian.org/tracker/CVE-2010-4664
- https://access.redhat.com/security/cve/cve-2010-4664
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2010-4664
- https://security-tracker.debian.org/tracker/CVE-2010-4664
Get alerted when CVE-2010-4664 or the next vulnerability affects your stack