What’s Vulnerable › Vulnerabilities
CVE-2011-0428
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-29 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) in ikiwiki before 3.20110122 could allow remote attackers to insert arbitrary JavaScript due to insufficient checking in comments.
Affected products
- ikiwiki: before 3.20110122 — fixed in 3.20110122
How to fix
Upgrade to a fixed version: ikiwiki 3.20110122. Check the vendor advisory for mitigations.
References
- https://ikiwiki.info/security/#index38h2
- https://security-tracker.debian.org/tracker/CVE-2011-0428
- https://ikiwiki.info/security/#index38h2
- https://security-tracker.debian.org/tracker/CVE-2011-0428
Get alerted when CVE-2011-0428 or the next vulnerability affects your stack