What’s Vulnerable › Vulnerabilities
CVE-2011-0480
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2011-01-14 · updated 2026-06-16
- Weakness: CWE-120
Description
Multiple buffer overflows in vorbis_dec.c in the Vorbis decoder in FFmpeg, as used in Google Chrome before 8.0.552.237 and Chrome OS before 8.0.552.344, allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact via a crafted WebM file, related to buffers for (1) the channel floor and (2) the channel residue.
Affected products
- Canonical Ubuntu Linux: 8.04, 9.10, 10.04, 10.10
- Debian Linux: 6.0
- Google Chrome: before 8.0.552.237 — fixed in 8.0.552.237
- Google ChromeOS: before 8.0.552.344 — fixed in 8.0.552.344
How to fix
Upgrade to a fixed version: Google Chrome 8.0.552.237; Google ChromeOS 8.0.552.344. Check the vendor advisory for mitigations.
References
- http://article.gmane.org/gmane.comp.video.ffmpeg.devel/122703
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=610550
- http://code.google.com/p/chromium/issues/detail?id=68115
- http://codereview.chromium.org/5964011
- http://codereview.chromium.org/6069005
- http://ffmpeg.mplayerhq.hu/
- http://git.ffmpeg.org/?p=ffmpeg.git%3Ba=commit%3Bh=13184036a6b1b1d4b61c91118c0896e9ad4634c3
- http://googlechromereleases.blogspot.com/2011/01/chrome-stable-release.html
- http://osvdb.org/70463
- http://roundup.ffmpeg.org/issue2548
- http://roundup.ffmpeg.org/issue2550
- http://secunia.com/advisories/42951
Get alerted when CVE-2011-0480 or the next vulnerability affects your stack