What’s Vulnerable › Vulnerabilities
CVE-2011-10019: Spreecommerce < 0.60.2 Search Parameter RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-13 · updated 2026-10-08
- Weakness: CWE-94
Description
Spreecommerce versions prior to 0.60.2 contains a remote command execution vulnerability in its search functionality. The application fails to properly sanitize input passed via the search[send][] parameter, which is dynamically invoked using Ruby’s send method. This allows attackers to execute arbitrary shell commands on the server without authentication.
Affected products
- spree: before 0.60.2 — fixed in 0.60.2
How to fix
Upgrade to a fixed version: spree 0.60.2. Check the vendor advisory for mitigations.
References
- https://github.com/orgs/spree
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/multi/http/spree_search_exec.rb
- https://web.archive.org/web/20111009192436/http://spreecommerce.com/blog/2011/10/05/remote-command-product-group/
- https://www.exploit-db.com/exploits/17941
- https://www.vulncheck.com/advisories/spreecommerce-search-parameter-rce
Get alerted when CVE-2011-10019 or the next vulnerability affects your stack