What’s Vulnerable › Vulnerabilities
CVE-2011-10026: Spreecommerce < 0.50.x API RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-20 · updated 2026-06-16
- Weakness: CWE-78
Description
Spreecommerce versions prior to 0.50.x contain a remote command execution vulnerability in the API's search functionality. Improper input sanitation allows attackers to inject arbitrary shell commands via the search[instance_eval] parameter, which is dynamically invoked using Ruby’s send method. This flaw enables unauthenticated attackers to execute commands on the server.
Affected products
- spree: before 0.50.1 — fixed in 0.50.1
How to fix
Upgrade to a fixed version: spree 0.50.1. Check the vendor advisory for mitigations.
References
- https://github.com/spree
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/multi/http/spree_searchlogic_exec.rb
- https://web.archive.org/web/20111120023342/http://spreecommerce.com/blog/2011/04/19/security-fixes
- https://www.exploit-db.com/exploits/17199
- https://www.vulncheck.com/advisories/spreecommerce-api-rce
Get alerted when CVE-2011-10026 or the next vulnerability affects your stack