What’s Vulnerable › Vulnerabilities
CVE-2011-10043: Module::Load versions before 0.22 for Perl allow arbitrary modules outside of @INC to be loaded
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-07-07
- Weakness: CWE-145
Description
Module::Load versions before 0.22 for Perl allow arbitrary modules outside of @INC to be loaded. Module names starting with "::" could be passed to the load function to specify arbitrary module paths. Attackers able to influence module names passed to load could use that bug to execute arbitrary code.
Affected products
- BINGOS Module::Load: before 0.22 — fixed in 0.22
How to fix
Upgrade to a fixed version: BINGOS Module::Load 0.22. Check the vendor advisory for mitigations.
References
- https://blogs.perl.org/users/michael_g_schwern/2011/10/how-not-to-load-a-module-or-bad-interfaces-make-good-people-do-bad-things.html
- https://metacpan.org/release/BINGOS/Module-Load-0.22/changes
- https://metacpan.org/release/BINGOS/Module-Load-0.22/diff/BINGOS/Module-Load-0.20/lib/Module/Load.pm
Get alerted when CVE-2011-10043 or the next vulnerability affects your stack