What’s Vulnerable › Vulnerabilities
CVE-2011-1017
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2011-03-01 · updated 2026-06-16
- Weakness: CWE-787
Description
Heap-based buffer overflow in the ldm_frag_add function in fs/partitions/ldm.c in the Linux kernel 2.6.37.2 and earlier might allow local users to gain privileges or obtain sensitive information via a crafted LDM partition table.
Affected products
- Canonical Ubuntu Linux: 8.04
- Linux kernel: before 2.6.37.2 — fixed in 2.6.37.2
How to fix
Upgrade to a fixed version: Linux kernel 2.6.37.2. Check the vendor advisory for mitigations.
References
- http://openwall.com/lists/oss-security/2011/02/23/16
- http://openwall.com/lists/oss-security/2011/02/24/14
- http://openwall.com/lists/oss-security/2011/02/24/4
- http://secunia.com/advisories/43716
- http://secunia.com/advisories/43738
- http://securityreason.com/securityalert/8115
- http://securitytracker.com/id?1025128
- http://www.pre-cert.de/advisories/PRE-SA-2011-01.txt
- http://www.securityfocus.com/archive/1/516615/100/0/threaded
- http://www.securityfocus.com/bid/46512
- http://www.ubuntu.com/usn/USN-1146-1
- http://openwall.com/lists/oss-security/2011/02/23/16
Get alerted when CVE-2011-1017 or the next vulnerability affects your stack