What’s Vulnerable › Vulnerabilities
CVE-2011-1028
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-20 · updated 2026-06-16
- Weakness: CWE-20
Description
The $smarty.template variable in Smarty3 allows attackers to possibly execute arbitrary PHP code via the sysplugins/smarty_internal_compile_private_special_variable.php file.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Smarty: from 3.0.0 before 3.0.7 — fixed in 3.0.7
How to fix
Upgrade to a fixed version: Smarty 3.0.7. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2011-1028
- https://seclists.org/oss-sec/2011/q1/313
- https://security-tracker.debian.org/tracker/CVE-2011-1028
- https://access.redhat.com/security/cve/cve-2011-1028
- https://seclists.org/oss-sec/2011/q1/313
- https://security-tracker.debian.org/tracker/CVE-2011-1028
Get alerted when CVE-2011-1028 or the next vulnerability affects your stack