What’s Vulnerable › Vulnerabilities
CVE-2011-1169
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-05-03 · updated 2026-06-16
- Weakness: CWE-129
Description
Array index error in the asihpi_hpi_ioctl function in sound/pci/asihpi/hpioctl.c in the AudioScience HPI driver in the Linux kernel before 2.6.38.1 might allow local users to cause a denial of service (memory corruption) or possibly gain privileges via a crafted adapter index value that triggers access to an invalid kernel pointer.
Affected products
- Linux kernel: before 2.6.38.1 — fixed in 2.6.38.1
How to fix
Upgrade to a fixed version: Linux kernel 2.6.38.1. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git%3Ba=commit%3Bh=4a122c10fbfe9020df469f0f669da129c5757671
- http://openwall.com/lists/oss-security/2011/03/18/1
- http://openwall.com/lists/oss-security/2011/03/18/2
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.38.1
- https://bugzilla.redhat.com/show_bug.cgi?id=688898
- http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git%3Ba=commit%3Bh=4a122c10fbfe9020df469f0f669da129c5757671
- http://openwall.com/lists/oss-security/2011/03/18/1
- http://openwall.com/lists/oss-security/2011/03/18/2
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.38.1
- https://bugzilla.redhat.com/show_bug.cgi?id=688898
Get alerted when CVE-2011-1169 or the next vulnerability affects your stack