What’s Vulnerable › Vulnerabilities
CVE-2011-1497
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-19 · updated 2026-06-16
- Weakness: CWE-79
Description
A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.
Affected products
- Ruby on Rails: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: Ruby on Rails 3.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/rails/rails/blob/38df020c95beca7e12f0188cb7e18f3c37789e20/actionpack/CHANGELOG
- https://www.openwall.com/lists/oss-security/2011/04/06/13
- https://github.com/rails/rails/blob/38df020c95beca7e12f0188cb7e18f3c37789e20/actionpack/CHANGELOG
- https://www.openwall.com/lists/oss-security/2011/04/06/13
Get alerted when CVE-2011-1497 or the next vulnerability affects your stack