What’s Vulnerable › Vulnerabilities
CVE-2011-1526
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-07-11 · updated 2026-06-16
- Weakness: CWE-269
Description
ftpd.c in the GSS-API FTP daemon in MIT Kerberos Version 5 Applications (aka krb5-appl) 1.0.1 and earlier does not check the krb5_setegid return value, which allows remote authenticated users to bypass intended group access restrictions, and create, overwrite, delete, or read files, via standard FTP commands, related to missing autoconf tests in a configure script.
Affected products
- Debian Linux: 5.0, 6.0
- Fedoraproject Fedora: 14, 15
- MIT Krb5-Appl: before 1.0.1 — fixed in 1.0.1
- Opensuse: 11.3, 11.4
- SUSE Linux Enterprise Server 15 SP1: 10-sp4, 11-sp1
- SUSE Linux Enterprise Server: 10-sp2, 10-sp3, 10-sp4, 11-sp1
- SUSE Linux Enterprise Software Development Kit: 10-sp4, 11-sp1
How to fix
Upgrade to a fixed version: MIT Krb5-Appl 1.0.1. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2011-July/062681.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-July/062699.html
- http://lists.opensuse.org/opensuse-security-announce/2011-10/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2012-01/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2012-01/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2012-01/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2012-01/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2012-01/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2012-01/msg00014.html
- http://secunia.com/advisories/45145
- http://secunia.com/advisories/45157
- http://secunia.com/advisories/48101
Get alerted when CVE-2011-1526 or the next vulnerability affects your stack