What’s Vulnerable › Vulnerabilities
CVE-2011-1593
- Severity: medium (CVSS 4.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2011-05-03 · updated 2026-06-16
- Weakness: CWE-190
Description
Multiple integer overflows in the next_pidmap function in kernel/pid.c in the Linux kernel before 2.6.38.4 allow local users to cause a denial of service (system crash) via a crafted (1) getdents or (2) readdir system call.
Affected products
- Canonical Ubuntu Linux: 8.04
- Linux kernel: before 2.6.38.4 — fixed in 2.6.38.4
- Red Hat Enterprise Linux: 5.0
- RedHat Enterprise Linux Aus: 5.6
- RedHat Enterprise Linux Desktop: 5.0
- RedHat Enterprise Linux Eus: 5.6
- RedHat Enterprise Linux Server: 5.0
- RedHat Enterprise Linux Workstation: 5.0
How to fix
Upgrade to a fixed version: Linux kernel 2.6.38.4. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=c78193e9c7bcbf25b8237ad0dec82f805c4ea69b
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=d8bdc59f215e62098bc5b4256fd9928bf27053a1
- http://groups.google.com/group/fa.linux.kernel/msg/4a28ecb7f755a88d?dmode=source
- http://openwall.com/lists/oss-security/2011/04/19/1
- http://openwall.com/lists/oss-security/2011/04/20/1
- http://rhn.redhat.com/errata/RHSA-2011-0927.html
- http://secunia.com/advisories/44164
- http://securitytracker.com/id?1025420
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.38.4
- http://www.securityfocus.com/bid/47497
- http://www.ubuntu.com/usn/USN-1146-1
- https://bugzilla.redhat.com/show_bug.cgi?id=697822
Get alerted when CVE-2011-1593 or the next vulnerability affects your stack