What’s Vulnerable › Vulnerabilities

CVE-2011-1755

Description

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Affected products

How to fix

Upgrade to a fixed version: macOS 10.6.8, 10.7.2; Apple Mac Os X Server 10.6.8, 10.7.2; Jabberd2 2.2.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2011-1755 or the next vulnerability affects your stack