What’s Vulnerable › Vulnerabilities
CVE-2011-1762
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-18 · updated 2026-06-16
- Weakness: CWE-284
Description
A flaw exists in Wordpress related to the 'wp-admin/press-this.php 'script improperly checking user permissions when publishing posts. This may allow a user with 'Contributor-level' privileges to post as if they had 'publish_posts' permission.
Affected products
- WordPress: before 3.0.6; from 3.1 before 3.1.2 — fixed in 3.0.6, 3.1.2
How to fix
Upgrade to a fixed version: WordPress 3.0.6, 3.1.2. Check the vendor advisory for mitigations.
References
- https://wordpress.org/support/wordpress-version/version-3-1-2/
- https://wordpress.org/support/wordpress-version/version-3-1-2/
Get alerted when CVE-2011-1762 or the next vulnerability affects your stack