What’s Vulnerable › Vulnerabilities
CVE-2011-1776
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-09-06 · updated 2026-06-16
- Weakness: CWE-119
Description
The is_gpt_valid function in fs/partitions/efi.c in the Linux kernel before 2.6.39 does not check the size of an Extensible Firmware Interface (EFI) GUID Partition Table (GPT) entry, which allows physically proximate attackers to cause a denial of service (heap-based buffer overflow and OOPS) or obtain sensitive information from kernel heap memory by connecting a crafted GPT storage device, a different vulnerability than CVE-2011-1577.
Affected products
- Linux kernel: before 2.6.39 — fixed in 2.6.39
- RedHat Enterprise Linux Desktop: 5.0
- RedHat Enterprise Linux Server: 5.0
- RedHat Enterprise Linux Server Aus: 5.6
- RedHat Enterprise Linux Server Eus: 5.6
- RedHat Enterprise Linux Workstation: 5.0
How to fix
Upgrade to a fixed version: Linux kernel 2.6.39. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=fa039d5f6b126fbd65eefa05db2f67e44df8f121
- http://openwall.com/lists/oss-security/2011/05/10/4
- http://rhn.redhat.com/errata/RHSA-2011-0927.html
- http://securityreason.com/securityalert/8369
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.39
- http://www.pre-cert.de/advisories/PRE-SA-2011-04.txt
- http://www.securityfocus.com/bid/47796
- https://bugzilla.redhat.com/show_bug.cgi?id=703026
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=fa039d5f6b126fbd65eefa05db2f67e44df8f121
- http://openwall.com/lists/oss-security/2011/05/10/4
- http://rhn.redhat.com/errata/RHSA-2011-0927.html
- http://securityreason.com/securityalert/8369
Get alerted when CVE-2011-1776 or the next vulnerability affects your stack