What’s Vulnerable › Vulnerabilities
CVE-2011-1829
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-07-27 · updated 2026-06-16
- Weakness: CWE-20
Description
APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.
Affected products
- Canonical Ubuntu Linux: 11.04
- Debian Advanced Package Tool: before 0.8.15.2 — fixed in 0.8.15.2
How to fix
Upgrade to a fixed version: Debian Advanced Package Tool 0.8.15.2. Check the vendor advisory for mitigations.
References
- http://launchpadlibrarian.net/75126628/apt_0.8.13.2ubuntu2_0.8.13.2ubuntu4.1.diff.gz
- http://packages.debian.org/changelogs/pool/main/a/apt/current/changelog
- http://www.securityfocus.com/bid/48671
- http://www.ubuntu.com/usn/USN-1169-1
- https://exchange.xforce.ibmcloud.com/vulnerabilities/68560
- https://launchpad.net/bugs/784473
- https://launchpad.net/ubuntu/+archive/primary/+sourcepub/1817196/+listing-archive-extra
- http://launchpadlibrarian.net/75126628/apt_0.8.13.2ubuntu2_0.8.13.2ubuntu4.1.diff.gz
- http://packages.debian.org/changelogs/pool/main/a/apt/current/changelog
- http://www.securityfocus.com/bid/48671
- http://www.ubuntu.com/usn/USN-1169-1
- https://exchange.xforce.ibmcloud.com/vulnerabilities/68560
Get alerted when CVE-2011-1829 or the next vulnerability affects your stack