What’s Vulnerable › Vulnerabilities
CVE-2011-2207
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-27 · updated 2026-06-16
- Weakness: CWE-295
Description
dirmngr before 2.1.0 improperly handles certain system calls, which allows remote attackers to cause a denial of service (DOS) via a specially-crafted certificate.
Affected products
- Debian Linux: 8.0
- GnuPG: before 2.1.0 — fixed in 2.1.0
- Red Hat Enterprise Linux: 6.0
How to fix
Upgrade to a fixed version: GnuPG 2.1.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2011-2207
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=627377
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-2207
- https://security-tracker.debian.org/tracker/CVE-2011-2207
- https://www.openwall.com/lists/oss-security/2011/06/15/6
- https://access.redhat.com/security/cve/cve-2011-2207
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=627377
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-2207
- https://security-tracker.debian.org/tracker/CVE-2011-2207
- https://www.openwall.com/lists/oss-security/2011/06/15/6
Get alerted when CVE-2011-2207 or the next vulnerability affects your stack