What’s Vulnerable › Vulnerabilities

CVE-2011-2483

Description

crypt_blowfish before 1.1, as used in PHP before 5.3.7 on certain platforms, PostgreSQL before 8.4.9, and other products, does not properly handle 8-bit characters, which makes it easier for context-dependent attackers to determine a cleartext password by leveraging knowledge of a password hash.

Affected products

How to fix

Upgrade to a fixed version: Openwall Crypt Blowfish 1.1; PHP 5.3.7; PostgreSQL 8.2.22, 8.3.16, 8.4.9, 9.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2011-2483 or the next vulnerability affects your stack