What’s Vulnerable › Vulnerabilities
CVE-2011-2497
- Severity: high (CVSS 8.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-08-29 · updated 2026-06-16
- Weakness: CWE-191
Description
Integer underflow in the l2cap_config_req function in net/bluetooth/l2cap_core.c in the Linux kernel before 3.0 allows remote attackers to cause a denial of service (heap memory corruption) or possibly have unspecified other impact via a small command-size value within the command header of a Logical Link Control and Adaptation Protocol (L2CAP) configuration request, leading to a buffer overflow.
Affected products
- Linux kernel: before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: Linux kernel 3.0. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=7ac28817536797fd40e9646452183606f9e17f71
- http://marc.info/?l=linux-kernel&m=130891911909436&w=2
- http://securityreason.com/securityalert/8359
- http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.0
- http://www.openwall.com/lists/oss-security/2011/06/24/9
- http://www.openwall.com/lists/oss-security/2011/06/27/3
- http://www.osvdb.org/74679
- http://www.securityfocus.com/bid/48472
- https://bugzilla.redhat.com/show_bug.cgi?id=716805
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=7ac28817536797fd40e9646452183606f9e17f71
- http://marc.info/?l=linux-kernel&m=130891911909436&w=2
- http://securityreason.com/securityalert/8359
Get alerted when CVE-2011-2497 or the next vulnerability affects your stack