What’s Vulnerable › Vulnerabilities
CVE-2011-2501
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2011-07-17 · updated 2026-06-16
- Weakness: CWE-125
Description
The png_format_buffer function in pngerror.c in libpng 1.0.x before 1.0.55, 1.2.x before 1.2.45, 1.4.x before 1.4.8, and 1.5.x before 1.5.4 allows remote attackers to cause a denial of service (application crash) via a crafted PNG image that triggers an out-of-bounds read during the copying of error-message data. NOTE: this vulnerability exists because of a CVE-2004-0421 regression. NOTE: this is called an off-by-one error by some sources.
Affected products
- Canonical Ubuntu Linux: 8.04, 10.04, 10.10, 11.04
- Debian Linux: 5.0, 6.0
- Fedoraproject Fedora: 14
- pnggroup libpng: from 1.0.0 before 1.0.55; from 1.2.0 before 1.2.45; from 1.4.0 before 1.4.8; from 1.5.0 before 1.5.4 — fixed in 1.0.55, 1.2.45, 1.4.8, 1.5.4
How to fix
Upgrade to a fixed version: pnggroup libpng 1.0.55, 1.2.45, 1.4.8, 1.5.4. Check the vendor advisory for mitigations.
References
- http://libpng.git.sourceforge.net/git/gitweb.cgi?p=libpng/libpng%3Ba=commit%3Bh=65e6d5a34f49acdb362a0625a706c6b914e670af
- http://lists.fedoraproject.org/pipermail/package-announce/2011-July/062720.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-July/063118.html
- http://secunia.com/advisories/45046
- http://secunia.com/advisories/45289
- http://secunia.com/advisories/45405
- http://secunia.com/advisories/45415
- http://secunia.com/advisories/45460
- http://secunia.com/advisories/45486
- http://secunia.com/advisories/45492
- http://secunia.com/advisories/49660
- http://security.gentoo.org/glsa/glsa-201206-15.xml
Get alerted when CVE-2011-2501 or the next vulnerability affects your stack