What’s Vulnerable › Vulnerabilities
CVE-2011-2522
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2011-07-29 · updated 2026-06-16
- Weakness: CWE-352
Description
Multiple cross-site request forgery (CSRF) vulnerabilities in the Samba Web Administration Tool (SWAT) in Samba 3.x before 3.5.10 allow remote attackers to hijack the authentication of administrators for requests that (1) shut down daemons, (2) start daemons, (3) add shares, (4) remove shares, (5) add printers, (6) remove printers, (7) add user accounts, or (8) remove user accounts, as demonstrated by certain start, stop, and restart parameters to the status program.
Affected products
- Canonical Ubuntu Linux: 8.04, 10.04, 10.10, 11.04
- Debian Linux: 5.0, 6.0, 7.0
- Samba: from 3.0.0 before 3.3.16; from 3.4.0 before 3.4.14; from 3.5.0 before 3.5.10 — fixed in 3.3.16, 3.4.14, 3.5.10
How to fix
Upgrade to a fixed version: Samba 3.3.16, 3.4.14, 3.5.10. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN29529126/index.html
- http://marc.info/?l=bugtraq&m=133527864025056&w=2
- http://osvdb.org/74071
- http://samba.org/samba/history/samba-3.5.10.html
- http://secunia.com/advisories/45393
- http://secunia.com/advisories/45488
- http://secunia.com/advisories/45496
- http://securityreason.com/securityalert/8317
- http://securitytracker.com/id?1025852
- http://ubuntu.com/usn/usn-1182-1
- http://www.debian.org/security/2011/dsa-2290
- http://www.exploit-db.com/exploits/17577
Get alerted when CVE-2011-2522 or the next vulnerability affects your stack