What’s Vulnerable › Vulnerabilities
CVE-2011-2694
- Severity: low (CVSS 2.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-07-29 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the chg_passwd function in web/swat.c in the Samba Web Administration Tool (SWAT) in Samba 3.x before 3.5.10 allows remote authenticated administrators to inject arbitrary web script or HTML via the username parameter to the passwd program (aka the user field to the Change Password page).
Affected products
- Canonical Ubuntu Linux: 8.04, 10.04, 10.10, 11.04
- Debian Linux: 5.0, 6.0, 7.0
- Samba: from 3.0.0 before 3.3.16; from 3.4.0 before 3.4.14; from 3.5.0 before 3.5.10 — fixed in 3.3.16, 3.4.14, 3.5.10
How to fix
Upgrade to a fixed version: Samba 3.3.16, 3.4.14, 3.5.10. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN63041502/index.html
- http://osvdb.org/74072
- http://samba.org/samba/history/samba-3.5.10.html
- http://secunia.com/advisories/45393
- http://secunia.com/advisories/45488
- http://secunia.com/advisories/45496
- http://securitytracker.com/id?1025852
- http://ubuntu.com/usn/usn-1182-1
- http://www.debian.org/security/2011/dsa-2290
- http://www.itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c03008543
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:121
- http://www.samba.org/samba/security/CVE-2011-2694
Get alerted when CVE-2011-2694 or the next vulnerability affects your stack