What’s Vulnerable › Vulnerabilities
CVE-2011-2707
- Severity: medium (CVSS 6.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-05-24 · updated 2026-06-16
- Weakness: CWE-200
Description
The ptrace_setxregs function in arch/xtensa/kernel/ptrace.c in the Linux kernel before 3.1 does not validate user-space pointers, which allows local users to obtain sensitive information from kernel memory locations via a crafted PTRACE_SETXTREGS request.
Affected products
- Linux kernel: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: Linux kernel 3.1. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=0d0138ebe24b94065580bd2601f8bb7eb6152f56
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1
- http://www.openwall.com/lists/oss-security/2011/07/20/18
- https://github.com/torvalds/linux/commit/0d0138ebe24b94065580bd2601f8bb7eb6152f56
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=0d0138ebe24b94065580bd2601f8bb7eb6152f56
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1
- http://www.openwall.com/lists/oss-security/2011/07/20/18
- https://github.com/torvalds/linux/commit/0d0138ebe24b94065580bd2601f8bb7eb6152f56
Get alerted when CVE-2011-2707 or the next vulnerability affects your stack