What’s Vulnerable › Vulnerabilities
CVE-2011-2902
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-30 · updated 2026-06-16
- Weakness: CWE-20
Description
zxpdf in xpdf before 3.02-19 as packaged in Debian unstable and 3.02-12+squeeze1 as packaged in Debian squeeze deletes temporary files insecurely, which allows remote attackers to delete arbitrary files via a crafted .pdf.gz file name.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Glyphandcog Xpdf: before 3.02-19 — fixed in 3.02-19
How to fix
Upgrade to a fixed version: Glyphandcog Xpdf 3.02-19. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/02/08/5
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=635849
- https://security-tracker.debian.org/tracker/CVE-2011-2902/
- http://www.openwall.com/lists/oss-security/2014/02/08/5
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=635849
- https://security-tracker.debian.org/tracker/CVE-2011-2902/
Get alerted when CVE-2011-2902 or the next vulnerability affects your stack