What’s Vulnerable › Vulnerabilities
CVE-2011-2906
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-05-24 · updated 2026-06-16
- Weakness: CWE-400
Description
Integer signedness error in the pmcraid_ioctl_passthrough function in drivers/scsi/pmcraid.c in the Linux kernel before 3.1 might allow local users to cause a denial of service (memory consumption or memory corruption) via a negative size value in an ioctl call. NOTE: this may be a vulnerability only in unusual environments that provide a privileged program for obtaining the required file descriptor.
Affected products
- Linux kernel: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: Linux kernel 3.1. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=b5b515445f4f5a905c5dd27e6e682868ccd6c09d
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1
- http://www.openwall.com/lists/oss-security/2011/08/09/8
- https://github.com/torvalds/linux/commit/b5b515445f4f5a905c5dd27e6e682868ccd6c09d
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=b5b515445f4f5a905c5dd27e6e682868ccd6c09d
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1
- http://www.openwall.com/lists/oss-security/2011/08/09/8
- https://github.com/torvalds/linux/commit/b5b515445f4f5a905c5dd27e6e682868ccd6c09d
Get alerted when CVE-2011-2906 or the next vulnerability affects your stack